Вопросы с тегом "sbt"

0

Не можете решить символа произвольного

Я пытаюсь реализовать ля моего типа как следовать: import cats._ import org.scalacheck.{Arbitrary, Gen} object Server { sealed trait ServerHealth case object ServerOnline extends ServerHealth case object ServerOffline extends ServerHeal...
1

Добавить зависимостей Maven для проекта СБТ

Я пытаюсь ссылаться на зависимость проекта Maven в моей build.sbt файл. Я понимаю, мне нужно добавить дополнительный resolver моего файла, так как проект хранится во внутреннем магазине artifactory build.sbt libraryDependencies ++= Seq( "org.apa...
0

Ошибке типа noclassdeffounderror при запуске Скала/качать программы с SBT

Я пытаюсь скомпилировать старый проект со всего марта 2015 года. Я не трогал его с тех пор. Проект написан на Scala с библиотекой качания, и средство построения в. Видимо мой build.sbt нуждается в обновлении файла. Покопавшись в сети, я обнаружил, ...
0

Почему подпроекты не признает зависимости?

Я определил два суб-проектов, которая выглядит следующим образом: val Http4sVersion = "0.21.0-M4" val CirceVersion = "0.12.1" val Specs2Version = "4.7.0" val LogbackVersion = "1.2.3" val ScalaTestVersion = "3.0.8" val TestContainerVersion = "1.11.3...
0

Как отключить проверку контрольной суммы в СБТ с интеграцией новых coursier

Я пытаюсь извлечь некоторые пакеты из репозитория Maven Енисей. К сожалению, для некоторых есть файлы, .sha1 файлов контрольной суммы являются неверными. Я пробовал работать вокруг этого, задавая update / checksums := Nil в , но это не мешает 1.3....
0

Можете создать несколько файлов с помощью foreachBatch в Искре (этот код работает теперь)

Я хочу сохранять файлы в различных направлениях, используя foreachBatch , код выполняется нормально, но foreachBatch не работает так, как хотели. Просьба помочь мне с этим, если у вас есть какие-либо улики. import org.apache.spark.sql.SparkSession i...
1

Как зависимости настройки в библиотеке SBT для версии как 1.0.0-М10 и выше

Я хочу написать библиотеку, которая должна работать с артефактом версия и выше, например, , , . Но версия должна выбрать пользователей библиотеки. Я устал "org" %%%% "scanamo" %% "1.0.+" в SBT, но не могу найти какой-либо версии. Как я могу н...
0

Неразрешенных зависимостей при попытке запустить СБТ

Пытаясь следовать примеру в О'Рейли "Программирование книга Скала". Скачал потом установил SBT с: самогон установить [email protected] Похоже, это удалось. При вводе "СБТ" или "СБТ-V" в командной строке (Bash на Мак) я получаю: :::::::::::::::::::::...